2

If I run:

$ cleos -u <api endpoint> -j --full <account> 

I do not get all the actions. I don't know what the default range is. So I tried:

$ cleos -u <api endpoint> -j --full <account> 0 1000 

Now I am getting all my actions as I have under 1000 so far. So far I don't see how I can always get all the actions for a given account without making up large number for the range. Any ideas?

Also, in another SO post I was adviced not to use the inline_traces keys to find my actions. But I do not see how I can find all the actions without recursively traversing the inline_traces key.

For example, I have a lot of actions like eos.names refunds and they are only available in inline_traces branch of the JSON data structure.

What am I doing wrong?

6
  • Also, I don't see a datestamp for each action the JSON feed returned by get_actions API call for an account. Should I assume the action timestamp to be the block_time?
    – Kabir
    Jun 22, 2018 at 4:30
  • What plugins do you have enabled on this machine?
    – ToughPal
    Jun 22, 2018 at 17:57
  • The api endponit points to a node producer's system so does it matter what EOS plugins are turned on on the machine where I compiled the cleos. I basically cloned the eosio source and ran the build script to build cleos. So default plugins should be on but I am using a remote API endpoint since I haven't connected my eos node to mainnet, which is the next step in my EOSIO TODO list. :)
    – Kabir
    Jun 23, 2018 at 3:13
  • the default returns last 20 records
    – Jimmy Guo
    Jun 26, 2018 at 2:24
  • Yes, I know of that and I mentioned 0 1000 in my question. So the number of records is not the issue. What seems to the case with "get actions" is that it only reports the actions initiated by an account. When an account is OUTBID in an eos.names contract, the contract refunds the initial bid by the account. This is the action that is not accessible by the "get actions" on a given account.
    – Kabir
    Jun 26, 2018 at 4:42

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.