1

I can recreate this issue every time on Ubuntu build and I have to be doing something wrong because I'm not seeing others describe it.

I build 1.0.6 (also happened with 1.0.5). I've deleted everything twice now and did new clones and build.

I run nodeos and then create wallet (default). I unlock the wallet. I create two keys. I import those keys into my default wallet. I try to create account with my two public keys and get the following error:

"Error 3090003: provided keys, permissions, and delays do not satisfy declared authorizations"

Based on some searching I do an import of the eosio private key. (I'm guessing this is where my error is coming in, but I don't really know what to do.)

I try to create the account again and get the

"Failed with error: Assert Exception (10) prefix_matches(prefix, base58str): Signature has invalid prefix: SIG_K1_..."

I have tried changing "SIG" to "TES" in signatures.hpp and rebuilding:

namespace fc { namespace crypto {
   namespace config {
      constexpr const char* signature_base_prefix = "SIG";
      constexpr const char* signature_prefix[] = {
         "K1",
         "R1"
      };
   };

Every time I get the same exact error. Any help would be appreciated.

  • Let me see your cmd, you must strictly observe the following usage. "Usage: cleos create account [OPTIONS] creator name OwnerKey [ActiveKey]" – user2686071 Jun 24 '18 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.