Here's how I'm running nodeos:

nodeos -e -p eosio --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin

I already tried deleting the "data" folder in .local/share/eosio/nodeos/

and tried running it again. It says that the addr is already in use:

995027ms thread-0   http_plugin.cpp:338           plugin_startup       ] http service failed to start: Address already in use

995030ms thread-0   main.cpp:133                  main                 ] Address already in use

But there's no nodeos process running. In fact, I'm on an AWS and ps -a says there's only one process running. So it's gotta be something to do with the data files / config files.

Any ideas on how to complete a full reset of the blockchain?

  • What does a ps -ax say on the system? That will list all processes on the box, not just the ones belonging to your account. Commented Jun 29, 2018 at 19:49

1 Answer 1


I ran command ps -ax which showed a nodeos process running.

I then run pkill nodeos and then deleted .local/shared/eosio/nodeos/data/blocks and .local/shared/eosio/nodeos/data/state

Which fixed my problem. it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.