I am trying to compile the Hello World Tutorial, using the following command:

eosiocpp -o hello.wast hello.cpp

However, this does not work, giving the error:

hello.cpp:1:10: fatal error: 'eosiolib/eosio.hpp' file not found
#include <eosiolib/eosio.hpp>

There were suggestions in the Git Issue Tracker that this could be fixed by running:

sudo make install

in the eos/build directory, but I tried this and it didn't work for me.

Does anyone know what is wrong or how to fix it?

  • I found a temporary solution that pushes the problem along to a different point. If you make a symbolic link to the eos/contracts/eoslib directory in the folder where you are trying to use eosiocpp, then you can get further with the compilation. Leading to the new problem of the stdint.h header not being found. Will post more updates as I make further progress. – Phillip Hamnett - EOS42 Jul 16 at 5:36
  • 1
    my suggestion would be to erase the eos/build, run eosio_build.sh again, go into the new eos/build folder and run sudo make install – Leo Ribeiro Jul 16 at 11:35
up vote 1 down vote accepted

I have solved my own problem.

This seems to be a bug in the build script for EOS (see Github Issue 4690) that isn't fixed for all platforms.

I was running EOS on Ubuntu 18.04. Have now switched down to 16.04 and everything works fine.

0 down vote

As a workaround, revert locally the commit which introduced a regression, then build and install again:

cd $HOME/eos
git revert -n 67393d7
./eosio_build.sh
cd build
sudo make install

eosiocpp should work now fine.

Full details within:

https://github.com/EOSIO/eos/issues/5133

  • I do the same for unbuntu 16.04 when i compile my file i got the error /usr/local/eosio/include/eosiolib/symbol.hpp:2:10: fatal error: 'eosiolib/core_symbol.hpp' file not found #include <eosiolib/core_symbol.hpp> it seems this time this found asset.hpp but not able to find core_symbol.hpp can you please suggest me what am i doing wrong here – Nirdesh Kumar Choudhary 17 hours ago

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.