I am following the steps in this tutorial:


and everything has worked so far. However, when I try this:

"Also go to this address in the browser to check that RPC interface is working: http://localhost:8888/v1/chain/get_info "

I get no output at all. My installation is on Ubuntu.

  • Does $ cleos get info work after you complete the rest of the steps on the page?
    – confused00
    Jul 20 '18 at 15:36
  • @larsemanse do you want to write an answer for the steps you did or shall I delete this question?
    – TeeAttack42
    Jul 20 '18 at 19:42
  • cleos get info working. But localhost:8888/v1/chain/get_info and curl http://localhost:8888/v1/chain/get_info doesn't work. How to fix it? I use docker. Jul 24 '18 at 10:11
  • maybe it's not running on localhost:8888?
    – confused00
    Jul 28 '18 at 13:07

This is happening because localhost is not relaying the browser's request to the docker container.

Run docker-machine ip default to get the ip for your docker container.

$ docker-machine ip default

Now try accessing the RPC interface from your browser using the returned ip address:


You should receive a json response similar to what was shown in the docs:

    "server_version": "0961a560",
    "chain_id": "cf057bbfb72640471fd910bcb67639c22df9f92470936cddc1ade0e2f2e7dc4f",
    "head_block_num": 13780,
    "last_irreversible_block_num": 13779,
    "last_irreversible_block_id": "000035d36e1ca29ba378081c574ab3b5ab4214ba29754dd42b512690a9f03e80",
    "head_block_id": "000035d4165c9225d7a04822d142fbcb15f997a6f2571dc7bae8437dea782205",
    "head_block_time": "2018-05-23T16:30:54",
    "head_block_producer": "eosio",
    "virtual_block_cpu_limit": 100000000,
    "virtual_block_net_limit": 1048576000,
    "block_cpu_limit": 99900,
    "block_net_limit": 1048576

This worked for me, lmk if you have any issues. I'm also new to docker, so edits to correct my terminology above are appreciated.

  • I did not find docker-machine, but I ran "docker inspect eosio" and a load of info was listed, including the correct ip adress I used that adress in my browser: and the info I was looking for got listed.
    – larsemanse
    Aug 9 '18 at 13:41
  • @larsemanse Its great that billbit could solve your problem. You should click "Accept answer" next to his answer so that others know that this solution worked for you. Jun 28 '19 at 8:22

Just use:

$ cleos get info

to check if the RPC interface is working.

  • That's not to check if RPC is working or not. It is to check whether your nodeos is working or not. To check RPC thing, you need to test HTTP API. Aug 8 '18 at 7:29


nodeos --http-server-address= // Mind No spaces around =

This worked for me. All other try with config.ini didn't work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.