I use docker cleos as below instruction: https://developers.eos.io/eosio-nodeos/docs/docker-quickstart Before the cleos command works fine, but recently the cleos only works for read type, when I run "cleos system buyram" or simillar command, there is error as below: Error 3200004: fail to resolve host Error Details: Error resolving "api.helloeos.com.cn:${url}" : Host not found (non-authoritative), try again later

I tried serveral API node, not work. The client version seems lower than server. any idea how to fix this? thanks.

2 Answers 2


First of all I would recommend upgrading your client to match the version of the servers, since there could be a mismatch in the format or structure of the data passed around or something like that.

Secondly, how are you specifying the host? This might also depend on your version of cleos, but if you're using a recent version, you would need to use something like

cleos --url https://api1.eosdublin.io <THE REST OF YOUR COMMAND>

so make sure you're specifying the parameter in the right way and including the http part (ideally https).

Good luck, and if it still doesn't work please add more details to your question so we can help.


Changing your path environment per below link might work, eosio commands will be found then:


Alternatively add $USER to docker might resolve the problem:

sudo usermod -a -G docker $USER

Reboot & retry

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.