I've just installed eosfactory and a fresh copy of EOS on my WSL ubuntu 18.04 and I'm failing all of the initial unit tests indicating there might be a problem with my install.

The tests fail at the assertion assert (not testnet.error)

It looks to me like the nodeos instance isn't running properly. Running the test script opens a bash terminal thing which looks like it's running nodeos, and it gets only to the following line before hanging:

2018-08-06T15:25:31.748 thread-0   net_plugin.cpp:3049           plugin_startup       ] starting listener, max clients is 25

Any ideas on how I can fix this awesome testing tool?

EDIT: After trying to start running the first tutorial for eosfactory it seems as if nodeos is actually running correctly (just in the background) but I run into a permissions error when I run sess.init():

enter image description here

up vote 3 down vote accepted

This looks like a consequence of the incompatibility between EOSIO v.1.1.x and EOSFactory v1.1. EOSFactory v1.1 is compatible only with EOSIO v1.0.8 and v1.0.9, not higher (the assumptions made in the release notes turned out to be over-optimistic).

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.