3

I'd like to create a new account using cleos that requires multiple signatures to perform owner and active authorizations. I tried the following but it didn't quite work.

./cleos set account permission testmultisig owner {"threshold":"2","keys":[{"key":"EOS8Re9txzHLCjtS1Hnkfnocgf4pPpQQqn2WXeQjAgLfWdoSR2bSQ","weight":"1"},{"key":"EOS7hFephCDUVDE8mcuBUhY9yEyBJ1VcFMBDktivhWHK9BD1Xd7yx","weight":"1"}],"accounts":[{"permission":{"actor":"testmultisig","permission":"owner"},"weight":"2"}]}

2
  • 1
    What error did you get? I think you should quote the JSON part.
    – kenorb
    May 10 '18 at 20:02
  • I have the exact same problem. It would be nice if you could post the result of your query. May 11 '18 at 15:45
1

When I skim your command I found that you forgot ' ' in the permission setting.

./cleos set account permission testmultisig owner '{"threshold":"2","keys":[{"key":"EOS8Re9txzHLCjtS1Hnkfnocgf4pPpQQqn2WXeQjAgLfWdoSR2bSQ","weight":"1"},{"key":"EOS7hFephCDUVDE8mcuBUhY9yEyBJ1VcFMBDktivhWHK9BD1Xd7yx","weight":"1"}],"accounts":[{"permission":"actor":"testmultisig","permission":"owner"},"weight":"2"}]}'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.