I know after running the nodeos and keosd . I run the cleos --url http://localhost:8888 get info

and I get the following json in my terminal window

  "server_version": "bf28f8bb",
  "chain_id": "cf057bbfb72640471fd910bcb67639c22df9f92470936cddc1ade0e2f2e7dc4f",
  "head_block_num": 99,
  "last_irreversible_block_num": 98,
  "last_irreversible_block_id": "00000062dda0c103551d1fcd41873e5bfd0c31b8fb477e00727957124349648c",
  "head_block_id": "00000063dfd6ec5ba621cd4b639477894f01e0d4d795a391ba2d0036feca2d6a",
  "head_block_time": "2018-08-21T08:45:41.500",
  "head_block_producer": "eosio",
  "virtual_block_cpu_limit": 220554,
  "virtual_block_net_limit": 1156544,
  "block_cpu_limit": 199900,
  "block_net_limit": 1048576,
  "server_version_string": "v1.2.1"

so my question is the last field "server_version_string":"v1.2.1" is my EOS version or not ? Actually i want to install EOS version 1.0.1 !

3 Answers 3


Like @Lonkly said it is Version 1.2.1.

As an alternative to his solution you could use an old docker image.

Check it out here from Docker Hub.

The advantage of this solution is that you do not have to build anything on your own and have to configure less. You can also easily switch between versions.

You can run it by pulling the image and running it with a specified version. The commands would look something like this, but you have to specify your own volume paths.

docker pull eosio/eos-dev:v1.0.1
docker run --rm --name eosio -d -p 8888:8888 -p 9876:9876 <volumes> eosio/eos-dev:v1.0.1 /bin/bash -c "nodeos -e -p eosio --plugin eosio::wallet_api_plugin --plugin eosio::wallet_plugin --plugin eosio::producer_plugin --plugin eosio::history_plugin --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin --plugin eosio::http_plugin -d /mnt/dev/data --config-dir /mnt/dev/config --http-server-address= --access-control-allow-origin=* --contracts-console"

Both of previous answers are valid.

Another alternative, a little bit more tricky, is this one: in you output you have, as first row "server_version": "bf28f8bb". This is the hash of the commit of your current version.

If you go on eos repository on github, under the tab releases (https://github.com/EOSIO/eos/releases) on the left you can se the commit hash of the release. Under 1.2.1 you have bf28f8b which is the same value of "server_version".

This confirms your version.


Correct, 1.2.1 is currently the latest EOS version. If you want 1.0.1 you can download it from here, then go inside the folder, sh eosio_build.sh , cd build and sudo make install I also see that you have a previous installation as you use cleos command, so you can remove it by running sudo sh eosio_uninstall.sh from within eos folder.

  • I have installed version 1.0.1 . After installing v1.0.1 if I run sudo sh eosio_uninstall.sh I will uninstall my EOS currently running ..? Commented Aug 21, 2018 at 12:03
  • yes, after you've build and installed previous eos, it has been written to /usr/local/eosio or whatever on your platform. By uninstalling, you will remove current installation. Then you can build and install 1.0.1 Commented Aug 21, 2018 at 12:21
  • My eos at /usr/local/share/eosio this path if I try to do sudo sh eosio_uninstall.sh it will show sh: 0: Can't open eosio_uninstall.sh . Path of my EOS where I clone is /home/nirdesh.kumar/EOS I also tried to uninstall it from here same error message pop up . Commented Aug 22, 2018 at 6:56
  • 1
    /usr/local/... is the place where you install executables. The eos directory with these .sh scripts is located elsewhere. How did you install eos? Docker/manual? Did you clone the code? can you just search for eosio_uninstall.sh on your HD? :) Commented Sep 6, 2018 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.