3

I have just configure EOS reading this article. Now when I run the command

./nodeos -e -p eosio --plugin eosio::wallet_api_plugin --plugin eosio::chain_api_plugin --plugin eosio::account_history_api_plugin

this gives me the following error:

2018-09-08T09:07:26.172 thread-0   main.cpp:131                  main                 ] /Users/abdulmanan7/eos/libraries/appbase/application.cpp(309): Throw in function appbase::abstract_plugin &appbase::application::get_plugin(const string &) const
Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::runtime_error> >
std::exception::what: unable to find plugin: eosio::wallet_api_plugin

I don't know what is the issue; can anyone help me out please?

When I remove wallect_api_plugin I get this error:

unable to find plugin: eosio::account_history_api_plugin
1

According to the release notes of v1.2.0, the wallet_api_plugin has been removed from nodeos:

  • it is no longer possible to run the wallet_plugin or wallet_api_plugin as part of nodeos. This configuration has not been recommended for many versions as it places private information in the same process space as unrelated RPCs and the execution environment for untrusted code (WebAssembly). This release officially removes the support.
| improve this answer | |
  • i update question please have a look again – Abdul Manan Sep 8 '18 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.