1

I was able to run Dawn 3, but ran into a snag with Dawn 4: Using a fresh CentOS7 VM in VirtualBox, building the dawn-v4.0.0 tag using the eosio_build.sh:

[ 80% ] Building CXX object libraries/testing/CmakeFiles/chain_tester.dir/test.cpp.o
/home/eos/eos/libraries/testing/test.cpp:4:10: fatal error: eosio.token/eosio.token.wast.hpp: No such file or directory
#include <eosio.token/eosio.token.wast.hpp>
compilation terminated.

I think output products were not created for the token contract. Looking under build/contracts I see that only the eosio.bios contract has .wast, .wast.hpp, .wasm but the other contracts under build only have the .abi output.

Mostly curious if anyone else ran into this or if it's just me.

3

I had the same error, and filed a bug (which has been assigned).

A short-term fix supplied by someone, which seems to work: go into build/contracts, run make, return to top level and run the original build script again.

| improve this answer | |
  • running make on the build directory worked for me on 4.0 – Rogério Richa May 18 '18 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.