1

Syncing my node, everything works fine. I get a warning though when processing transactions from eosforumdapp and eosforumcpp

info  2018-10-20T09:07:14.286 thread-1  mongo_db_plugin.cpp:481       consume_blocks       ] process_accepted_block,       time per: 1712, size: 465, time: 796163
warn  2018-10-20T09:07:15.226 thread-1  mongo_db_plugin.cpp:651       get_abi_serializer   ] 3015016 unsupported_abi_version_exception: ABI has an unsupported version
ABI has an unsupported version
    {}
    thread-1  abi_serializer.cpp:109 set_abi
warn  2018-10-20T09:07:15.226 thread-1  mongo_db_plugin.cpp:651       get_abi_serializer   ] n: eosforumdapp
info  2018-10-20T09:07:17.659 thread-1  mongo_db_plugin.cpp:456       consume_blocks       ] process_applied_transaction,  time per: 1456, size: 2073, time: 3019243
info  2018-10-20T09:07:17.821 thread-1  mongo_db_plugin.cpp:934       _process_accepted_bl ] block_num: 17314000

warn  2018-10-20T09:09:14.425 thread-1  mongo_db_plugin.cpp:651       get_abi_serializer   ] n: eosforumrcpp
warn  2018-10-20T09:09:15.961 thread-1  mongo_db_plugin.cpp:651       get_abi_serializer   ] 3015016 unsupported_abi_version_exception: ABI has an unsupported version
ABI has an unsupported version
    {}
    thread-1  abi_serializer.cpp:109 set_abi
warn  2018-10-20T09:09:15.961 thread-1  mongo_db_plugin.cpp:651       get_abi_serializer   ] n: eosforumdapp
info  2018-10-20T09:09:17.233 thread-1  mongo_db_plugin.cpp:456       consume_blocks       ] process_applied_transaction,  time per: 1483, size: 2073, time: 3074877

Running a non-producing node, non Docker. Latest eos version: 1.4.1 Relevant parts of my config.ini:

bnet-follow-irreversible = 0
bnet-no-trx = false
read-mode = read-only
validation-mode = light
mongodb-uri = mongodb://127.0.0.1:27017/EOS
mongodb-queue-size = 2048
mongodb-abi-cache-size = 2048
mongodb-block-start = 1
mongodb-store-blocks = 0
mongodb-store-transactions = 0
mongodb-store-transaction-traces = 0
mongodb-store-action-traces = 1
mongodb-filter-on = *
mongodb-filter-out = eosio:onblock:
mongodb-filter-out = gu2tembqgage::
mongodb-filter-out = blocktwitter::

wasm-runtime = wabt
p2p-max-nodes-per-host = 1
http-validate-host = false
https-client-validate-peers = 1
abi-serializer-max-time-ms = 10000
chain-state-db-size-mb = 32000
reversible-blocks-db-size-mb = 340
contracts-console = false
allowed-connection = any
max-clients = 100
network-version-match = 0
sync-fetch-span = 500
connection-cleanup-period = 30
max-implicit-request = 1500

access-control-allow-origin = *
access-control-allow-headers = *
access-control-allow-credentials = false
verbose-http-errors = true

plugin = eosio::chain_plugin
plugin = eosio::chain_api_plugin
plugin = eosio::bnet_plugin
plugin = eosio::mongo_db_plugin
plugin = eosio::http_plugin
1

Perhaps when you were synching, at that moment in time, eosforumrcpp had an invalid ABI version?

Right now, it seems like their versioning is fine:

$ cleos get abi eosforumrcpp
{                                 
  "version": "eosio::abi/1.0",
  ...
}

This should pass the check in abi_serializer.cpp:

EOS_ASSERT(starts_with(abi.version, "eosio::abi/1."), unsupported_abi_version_exception, "ABI has an unsupported version");

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.