I'm a CS major who wants to learn EOS dapp development, but I'm still very much a beginner. On my native Ubuntu machine, I ran

sudo docker network create eosnetwork

after the previous steps in the documentation (https://www.eosdocs.io/dappdevelopment/software/docker) and then

sudo docker run --name server --network=eosnetwork --rm -p 7777:7777 -i eosio/eos /bin/bash -c "nodeos -e -p eosio --plugin eosio::producer_plugin --plugin eosio::chain_api_plugin --plugin eosio::http_plugin -d /mnt/dev/data --http-server-address= --access-control-allow-origin=* --http-validate-host=0"

and they don't return to prompt after several minutes. Do I have to keep waiting? I hit ctrl-c and now if I run the first one again, it says Error response from daemon: network with name eosnetwork already exists. Do I have to simply wait more? How do I try it again?

Edit: I think those docs are outdated so I was referred to https://developers.eos.io/eosio-home/docs, and I think I successfully followed section 1.3, but in 1.4 I don't have enough physical memory to install CDT. What can I do?

  • Did you try docker logs --tail 10 server or something similar on another shell window? I estimate EOS is producing blocks, but you won't see it until you look into the logs.
    – TeeAttack42
    Oct 21 '18 at 21:18
  • I opened a new shell after having closed it a while ago, ran sudo docker start eosio and your command outputs Error: No such container: server. I was following another guide but someone on a Telegram channel referred me to developers.eos.io/eosio-home/docs and I followed that one until I got got the part where I have have to set up CDT and was told I don't have enough physical memory.
    – Daniel
    Oct 21 '18 at 21:43
  • Then replace that server with your containers name. For that second part: it is possible that your tries created unused images/containers which will block your memory. Try to find them by running docker ps -a and docker images.
    – TeeAttack42
    Oct 21 '18 at 21:54
  • I figured out that I just had to install cmake (wasn't a space issue). I tried the CDT install again and it got further but gives errors saying unable to find requested Boost libraries and unable to find Boost header file. I then installed Boost with brew but that didn't help.
    – Daniel
    Oct 21 '18 at 22:32
  • You should try to use the eosio/eos-dev image, so you don't have to build the CDT on your own.
    – TeeAttack42
    Oct 22 '18 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.