I have been using this tutorial from Medium to build my first smart contract. I've come far, finally got a nodeos local node up and running and producing blocks on my Ubuntu VM. I've hit a snag though when it comes to creating and compiling the Makefile. I tried using an IDE to create the Makefile, but it wasn't building. So I figured I'd use 'nano Makefile' in the command line and write it there and it worked! It starts building, then it hit numerous errors that causes it to stop.

Now in the tutorial, they change the name of the .cpp, .hpp, and .abi files to a custom name, in their case, mw-coin.cpp, mw-coin.hpp and mw-coin.abi. But it's still the eosio-token.cpp, eosio-token.hpp, etc files from the eos contracts folder. So I did the same. I made sure to change the #include path to #include "mycontract.hpp" at the top of the CPP file. So I don't think that's causing it.

Here's a read out of the errors I'm getting. They all seem to be from the HPP header file...

error: unknown type name 'account_name'

account_name issuer;

error: use of undeclared identifier 'accounts'

typedef eosio::multi_index accounts;

unknown type name 'account_name'

void sub_balance( account_name owner, asset value );

There are more, but that's just a few. Any help would be greatly appreciated. The tutorial either leaves something out, or I'm doing something wrong.

1 Answer 1


In recently version of eos_compiler.

Some data type are deprecated. including account_name ..
downgrade your compiler or edit code, or add typedef yourself.
good day :)

  • Thanks. I was able to get some help in the EOS Developer telegram group and found out the article had me using files with old syntax. I have a completely separate problem now which may require another post lol.
    – Brian M.
    Nov 21, 2018 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.