0

So I have nodeos up and running perfectly. I created a directory for a test project where I'm trying to use the eosio.token files in eosio.cdt to create a new token. When I run...

cleos set contract eosdevelopertwo ./eosdevelopertwo -p eosdevelopertwo@active

I get an error message that reads "Serialization Error Processing WASM"

The project folder in question has an a.out file that generates instead of an abi file. For some reason when I ran the command to generate an abi file, it created this. I also have a renamed eosio.token.cpp file and a renamed eosio.token.hpp file. I also have a WASM file that I was able to generate. So outside of an abi file...I should have everything.

When I ran...

eosio-cpp -g eosdevelopertwo.abi eosiodevelopertwo.cpp it generated an a.out file, not an abi file

I saw in another thread similar to this one, someone mentioned a config.ini file, but I'm not using Docker and a Docker folder is the only place where I found that. I'm running a local node on my VM. I feel like I'm very close. The only thing that seems strange is whenever I ran the commands to create the wasm and abi files...the command line always froze and didn't automatically pop up with a new line. The cursor would go to the next line and just keep blinking as if it was trying to process something and a temp file would appear in the folder.

I have to hit Control+C to get rid of that just so I can type on the next line. IDK if that has something to do with it, maybe my WASM and ABI files aren't complete or something. Maybe that's why I get an a.out file.

Any help would be much appreciated. I've come so far and I know I'm just missing something here.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.