0

I am running EOS on my computer as a local network. I created a smart contract and am able to invoke the actions using both cleos commands and through eosjs. When I run cleos get table command I see the multi-index tables populated as they should be...which means my smart contract is working fine.

However, when I run

cleos get actions 'account_name' 

to see all the actions performed by a specific account, I get an empty list as below:

# seq when contract::action => receiver trx id... args ===================================================================================

My nodeos is configured with filter-on option. Complete configuration below:

keosd --http-server-address=0.0.0.0:5555 & exec nodeos -e -p eosio --plugin eosio::producer_plugin --plugin eosio::chain_api_plugin --plugin eosio::history_plugin --plugin eosio::history_api_plugin --plugin eosio::http_plugin -d /mnt/dev/data --config-dir /mnt/dev/config --http-server-address=0.0.0.0:7777 --access-control-allow-origin=* --contracts-console --http-validate-host=false —filter-on='*'

What am I missing?

0

Please refer this issues on github it may resolve your query

https://github.com/EOSIO/eos/issues/3583

https://github.com/EOSIO/eos/issues/3915

  • Thank you. I had looked through these issues and as was mentioned in the comments my nodeos was run with history plugin and filter-on options. Not sure what else I am missing here! – Jyothi Dec 8 '18 at 13:12
  • try to hard reply blockchain by nodeos --hard-replay-blockchain this and after that try to get actions – Mr.Y Dec 10 '18 at 4:49
  • Will try thank you! – Jyothi Dec 10 '18 at 15:45
  • Anytime...Happy coding :-) – Mr.Y Dec 11 '18 at 4:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.