2

yesterday I created and launched a single node test net on MacOS. To shut it down I pressed CTRL + C and then shut down my computer a while after.

Today I tried to restart the block producer with nodeos and got this:

[mikeys-iMac:~ mikey$ nodeos
3086500ms thread-0   chain_plugin.cpp:125          plugin_initialize    ]
 initializing chain plugin
3086502ms thread-0   block_log.cpp:120             open                 ]
 Log is nonempty
3086502ms thread-0   block_log.cpp:123             open                 ]
 my->head->block_num(): 1 
3086502ms thread-0   block_log.cpp:129             open                 ]
 Index is nonempty
3086526ms thread-0   http_plugin.cpp:247           plugin_initialize    ]
 configured http to listen on 127.0.0.1:8888
3086526ms thread-0   net_plugin.cpp:2822           plugin_initialize    ]
 Initialize net plugin
3086526ms thread-0   net_plugin.cpp:2843           plugin_initialize    ]
 host: 0.0.0.0 port: 9876 
3086526ms thread-0   net_plugin.cpp:2915           plugin_initialize    ]
 my node_id is c483a327e508ab99d2039b4604ea4e8086dc84d9becd9f373f4df512d8397ad8
3086526ms thread-0   main.cpp:94                   main                 ]
 nodeos version 29c30f10
3086526ms thread-0   main.cpp:95                   main                 ]
 eosio root is /Users/mikey/Library/Application Support
3086527ms thread-0   chain_plugin.cpp:253          plugin_startup       ]
 starting chain in read/write mode
3086527ms thread-0   chain_plugin.cpp:258          plugin_startup       ]
 Blockchain started; head block is #1, genesis timestamp is 2018-03-02T12:00:00.000
3086527ms thread-0   http_plugin.cpp:285           plugin_startup       ]
 start listening for http requests
3086527ms thread-0   net_plugin.cpp:2927           plugin_startup       ]
 starting listener, max clients is 25
3086527ms thread-0   producer_plugin.cpp:381       plugin_startup       ] 
 producer plugin:  plugin_startup() begin
3086527ms thread-0   producer_plugin.cpp:397       plugin_startup       ]
 No producers configured! Starting as a validator
3086527ms thread-0   producer_plugin.cpp:401       plugin_startup       ]
 producer plugin:  plugin_startup() end

How do I make it start producing blocks again so that I can continue with the rest of the EOSIO tutorials?

Would also greatly appreciate a short explanation of correct starting / stopping procedures in a development environment. Thank you (:

  • Did you try running nodeos --resync? – Don P May 20 '18 at 6:05
  • I tried just then and got a response which included: 1347966ms thread-0 controller.cpp:1073 startup ] No head block in fork db, perhaps we need to replay 1347966ms thread-0 controller.cpp:264 initialize_fork_db ] Initializing new blockchain with genesis state 1348006ms thread-0 controller.cpp:208 init ] unconf_blocknum: 1 – Mikey Musch May 20 '18 at 6:26
  • What about nodeos --replay ? – Don P May 20 '18 at 6:44
  • I got the same thing as the previous comment with a few other lines of code that weren't red and don't sound like they are describing any issues – Mikey Musch May 20 '18 at 6:50
  • No producers configured! - Do you have a producer-name set in config.ini? – Don P May 20 '18 at 7:06
0

No producers configured! - You are trying to run nodeos without a block producer.

You can set a producer command line with -p <producername> in this case -p eosio

Alternatively, you can set the producer name in the config file which is generated when you first run nodeos.

nodeos uses a custom configuration folder. The location of this folder is determined by your system.

Mac OS: ~/Library/Application Support/eosio/nodeos/config

Linux: ~/.local/share/eosio/nodeos/config

The build seeds this folder with a default genesis.json file and a config.ini file

In config.ini you can add the following line to set the producer name to run nodeos without the extra option & argument:

 # Enable block production with the testnet producers
 producer-name = eosio

See 'Advanced Steps' in Creating and Launching a Single Node Testnet

As far as stopping/starting, CTRL + C should kill the process allowing you to start it right back up again. I can recreate the same error in Ubuntu if I suspend the process with CNTRL + Z and attempt to run nodeos again.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.