2

Trying to run nodeos with not internet connection produces the following error:

nodeos -e -p eosio --plugin eosio::chain_api_plugin --plugin eosio::history_api_plugin
2482204ms thread-0   chain_plugin.cpp:125          plugin_initialize    ] initializing chain plugin
2482215ms thread-0   block_log.cpp:120             open                 ] Log is nonempty
2482215ms thread-0   block_log.cpp:123             open                 ] my->head->block_num(): 6 
2482215ms thread-0   block_log.cpp:129             open                 ] Index is nonempty
2482229ms thread-0   http_plugin.cpp:249           plugin_initialize    ] failed to configure http to listen on 127.0.0.1:8888 (resolve: Host not found (authoritative))
2482229ms thread-0   net_plugin.cpp:2822           plugin_initialize    ] Initialize net plugin
2482229ms thread-0   net_plugin.cpp:2843           plugin_initialize    ] host: 0.0.0.0 port: 9876 
2482229ms thread-0   main.cpp:101                  main                 ] Throw location unknown (consider using BOOST_THROW_EXCEPTION)
Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >
std::exception::what: resolve: Host not found (authoritative)

I am running on ubuntu 18.04. It would be great to be able to run a single node testnet with no internet connection. Anything I can do to get that working?

  • I just tried running nodeos after disconnecting from my router (severing the internet connection) and it worked. I don't think it's an internet connection that's necessary, but a lo interface. When you run ifconfig what is the output? – Jackson Kelley May 20 '18 at 16:21
  • Lot's of boost ASIO related SO posts come up when you search the Host not found error, most related to hostname resolution. Could try the /etc/ fix found here. stackoverflow.com/questions/39984172/… – Jackson Kelley May 20 '18 at 17:47
  • Unfortunately same error. I added my host name to /etc/hosts. Before adding it hostname resolved to 127.0.0.2. I tried a few different configurations, but alas no go. I found lots of boost related posts too, maybe I will try the suggested code tweaks locally. Have you tried running it in aeroplane mode? Thanks very much for the help! – Martin H May 22 '18 at 11:14
  • If I’m not mistaken 127.0.0.2 is not correct. I did try disconnecting my wlan interface from the internet. I’ll try airplane mode when I get a second. – Jackson Kelley May 22 '18 at 13:50
  • I completely disabled networking and everything still worked. However, I just realized I've been using an older more stable version of EOS, so maybe that's why I'm not having the same problem you are. If you get completely stuck, you could try the same commit hash I'm on 74a4c7a04d651688d63d958c27fb57b5d9ae01fb – Jackson Kelley May 22 '18 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.