1

Till yesterday nodeos on my machine was working fine, today I installed eosjs after that eosio commands giving errors. Just like nodeos command giving following error:

Command 'nodeos' not found, did you mean:

  command 'nodefs' from deb noweb
  command 'nodejs' from deb nodejs

The tried solutions given for the same question but not working. Same is happening for cleos or any other commands of eosio. I follow these commands again but no change in errors.

git clone --recursive https://github.com/eosio/eosio.cdt --branch v1.4.1 --single-branch
cd eosio.cdt
./build.sh
sudo ./install.sh
  • Have look at this github.com/EOSIO/eos/issues/4883 – Mr.Y Feb 22 at 10:20
  • Thank you for sharing the link. I have gone through this link before. But didn't find any specific solution. – Varsh Feb 22 at 10:31
  • Go on eosio/build/programs/nodeos and then run ./nodeos in cmd try it – Mr.Y Feb 22 at 10:35
  • I am not getting this path eosio/build/programs/nodeos. Rather I tried cd ~/.local/share/eosio/nodeos/config – Varsh Feb 22 at 10:42
  • eosio OR eos is your main eos directory which you have cloned from git. – Mr.Y Feb 22 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.