0

The purpose of this installation is for me to be able to make /v1/chain/ mainnet API requests on a remote server that I have access to that won't disrupt mainnet itself. I tried using EOSNation/Blockmatrix's single mainnet node installer and ran into some problems. I'm not sure if the install failed due to incomplete syncing and/or if I have it configured incorrectly. I have no idea how to properly install, and then run the node with this scheme.

After a ~10 hour sync I ran into this error:

100% 4.99M=9h52m", "", "2019-04-16 22:44:27 (4.33 MB/s) - ‘blocks_backup.tar.gz’ saved [161655694957/161655694957]", "", "stop.sh: line 13: kill: (14543) - No such process", "tar: blocks/blocks.log: Wrote only 2560 of 10240 bytes", "tar: Exiting with failure status due to previous errors"], "stdout": "14543\nblocks/blocks.log", "stdout_lines": ["14543", "blocks/blocks.log"]}
        to retry, use: --limit @/root/eos-mainnet/management.retry

PLAY RECAP ********************************************************************************************************************************
<ServerIPRedacted>              : ok=2    changed=0    unreachable=0    failed=1

Server info:

Ubuntu 18.04 x64 / 16 GB Memory / 320 GB Disk + 250 GB

75G  blocks.log
151G blocks_backup.tar.gz

Filesystem 1G-blocks  Used  Available  Use%  Mounted on
/dev/vda1  310G       227G  84G        74%   /

ls -all /root/eos-mainnet = https://pastebin.com/raw/qc3k76i3

ls -all /opt/mainnet = https://pastebin.com/raw/QQqMKjyu

cat /opt/mainnet/config.ini = https://pastebin.com/raw/QALiyC6Q

0

It looks like you ran out of disk space, the chain is getting large!

If you just want to test getting a node up and running, you could restore from a snapshot rather than using a blocks backup. With ansible, set up a node with:

ansible-playbook eos.yml
ansible-playbook mainnet.yml

Then follow the snapshot instructions from: https://eosnode.tools/snapshots

  • Thanks. I deployed a server with 620 GB and was able to unpack everything but ran into issues which I have thoroughly documented here: https://pastebin.com/raw/038cyYuf I also text walled the EOS Infra server (sorry!) - I've only lightly played with EOSIO to this point and hope this thread can serve as a reference point for people launching (or attempting to launch) full mainnet nodes. Best, Kevin – eosftw Apr 18 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.