0

I've constructed a 4 nodeos testnet.

Initially, the first nodeos is the producer.

Then, I created setbp.json like the following.

{
"schedule":
[
{"producer_name":"eosio","block_signing_key":"EOS6MRyAjQq8ud7hVNYcfnVPJqcVpscN5So8BhtHuGYqET5GDW5CV"},
{"producer_name":"shlee","block_signing_key":"EOS6AyMKo2jovZP6Cdyug2w7GVeWR4J2UcdfVrT3JadEra1es4444"},
{"producer_name":"sanghwan","block_signing_key":"EOS5zHHAjGAfk17xHr9ghW55rpc4QP2afqYMrw1mHr6EmFZJ9epbX"},
{"producer_name":"inita","block_signing_key":"EOS6ZBJe2KUe5CyjkJTUyBY1u4fRSGywXYBapk1x6wEXALquh9Awb"}
]
}

Then, I run the following cleos command.

cleos --wallet-url http://172.31.19.24:8899 -u http://172.31.19.24:8888 push action eosio setprods setbp.json -p eosio@active

Then, I've gotten the following error for the 3 nodeos.

error 2019-05-17T01:58:59.500 thread-0 producer_plugin.cpp:1076 start_block ] Not producing block because I don't have the private key for EOS5zHHAjGAfk17xHr9ghW55rpc4QP2afqYMrw1mHr6EmFZJ9epbX

This is the command that I used to run the 2nd nodeos.

nodeos -e --producer-name shlee --plugin eosio::chain_api_plugin --plugin eosio::net_api_plugin --plugin eosio::history_api_plugin --access-control-allow-origin=* --http-validate-host=false --http-server-address 0.0.0.0:8889 --p2p-listen-endpoint 0.0.0.0:9877 --p2p-peer-address 172.31.19.24:9876 --p2p-max-nodes-per-host 10 --config-dir node2 --data-dir node2 --private-key [\"5KWxNkC5YDHF8dLwLfausst8zWvageXkCXx6qxUFXS3axoKEExu\",\"5HtWscYGJ49JdTXQjpUMPMRhbq6kz7QYs8EbKKsWK9qCVPtknyi\"] 

Here I gave two private keys for the account shlee. Furthermore, I've had already created the account shlee with two public keys of shlee.

Please let me know what happened.

0

When I run the 2nd nodeos, I have used two PRIVATE keys in the "--private-key" option. Actually, I was wrong. The first key should be a public key and the second should be the corresponding private key.

It seems that nodeos does not check whether the key pair is correct or not. I haven't seen any error message. Or maybe the error messages were scrolled so quickly that I couldn't see.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.