0

After following the guide to start my local node here I issue the commands

brew tap eosio/eosio
brew install eosio

keosd &

nodeos -e -p eosio \
--plugin eosio::producer_plugin \
--plugin eosio::chain_api_plugin \
--plugin eosio::http_plugin \
--access-control-allow-origin='*' \
--contracts-console \
--http-validate-host=false \
--verbose-http-errors >> nodeos.log 2>&1 &

tail -f nodeos.log

And normally the logs show blocks being produced.

Earlier today i did run

brew upgrade eosio to update to eosio 1.8.0

info  2019-07-08T10:41:51.809 thread-0  chain_plugin.cpp:395          operator()           ] Support for builtin protocol feature 'FIX_LINKAUTH_RESTRICTION' (with digest of 'e0fb64b1085cc5538970158d05a009c24e276fb94e1a0bf6a528b48fbc4ff526') is enabled with preactivation required
info  2019-07-08T10:41:51.809 thread-0  chain_plugin.cpp:395          operator()           ] Support for builtin protocol feature 'GET_SENDER' (with digest of 'f0af56d2c5a48d60a4a5b5c903edfb7db3a736a94ed589d0b797df33ff9d3e1d') is enabled with preactivation required
warn  2019-07-08T10:41:51.820 thread-0  chain_plugin.cpp:958          plugin_initialize    ] 13 N5boost10wrapexceptISt13runtime_errorEE: chainbase database format not compatible with this version of chainbase.
rethrow chainbase database format not compatible with this version of chainbase.: 
    {"what":"chainbase database format not compatible with this version of chainbase."}
    thread-0  chain_plugin.cpp:958 plugin_initialize
error 2019-07-08T10:41:51.820 thread-0  main.cpp:114                  main                 ] 13 N5boost10wrapexceptISt13runtime_errorEE: chainbase database format not compatible with this version of chainbase.
rethrow chainbase database format not compatible with this version of chainbase.: 
    {"what":"chainbase database format not compatible with this version of chainbase."}
    thread-0  chain_plugin.cpp:958 plugin_initialize

This far I have completely relied on brew to manage my install, is there a brew command to fix this?

2

The chainbase database generated by nodeos v1.7.x or earlier isn't compatible with nodeos v1.8.x. You need to replay blockchain. Delete data/state and data/blocks/reversible from your --data-dir path, and run nodeos with --replay-blockchain option. If your nodeos is connected to mainnet, it will take multiple days or weeks to replay from the genesis. You can find detailed instructions from here.

|improve this answer|||||
  • Thanks @conr2d I'm on a mac do you know where I can find the data-dir or if there is a command that will show it me? – Bill Jul 8 '19 at 10:58
  • @Bill You may find it from ~/Library/Application Support/eosio/nodeos/data. I'm using nodeos on Ubuntu, so not possible to verify this answer. If right, please leave a comment for other Mac users :) – conr2d Jul 8 '19 at 11:04
  • Yes that is the correct location on mac – Bill Jul 8 '19 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.