0

I am not able to compile, getting

error: unable to handle compilation, expected exactly one compiler job in ''

not able to compile a simple hello world smart contract

  • Too little information. Can you provide your case in detail, OS, CDT version, the way you try to build (just calling eosio-cpp or use cmake) etc? – conr2d Jul 13 at 16:20
  • mac mojave, CDT v1.6.1. docker run --rm --name eosio.cdt_v1.6.1 --volume /Users/bhaskaran/Documents/helloworld:/project -w /project eostudio/eosio.cdt:v1.6.1 /bin/bash -c "eosio-cpp -abigen -I include -R -contract helloworld -o helloworld.wasm src/helloworld.cpp" error: unable to handle compilation, expected exactly one compiler job in '' Error while processing /project/helloworld. abigen error – Bhaskar Jul 13 at 16:27
  • still struggling to fix this. need help – Bhaskar Jul 13 at 17:18
0

I experienced the same problem and i was able to fix it by creating an include folder and put the .hpp file there and change the #include ".hpp" to #include <.hpp> from .cpp file.

-1

eosio-cpp build command parameters were wrong. i am able to fix it by setting the right include path

  • Bhaskar do you mind elaborating on how the include paths changed? I'm running into the same issue with a default new project in ESIO studio with everything latest. Tried all sorts of include paths nothing works.. – zanedev Jul 15 at 0:46
  • 1
    Its great that you solved your own problem, and providing a full, detailed explanation of your solution will help others in the future. – Phillip Hamnett - EOS42 Jul 15 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.