0

enter image description hereI have done my research. All I found is people recommending me to use eosio.token to create a eos token. The issue is it won't load in eos studio. I am just wondering is there any tutorials (preferably video) on the subject.

https://www.youtube.com/watch?v=GgwBb2DY0bQ <--- won't work with eos studio

https://github.com/filipmartinsson/eos/tree/master/currency <—-is this template dated?

  • Be sure to accept given answers if they properly address your issue. This makes the question/answer easier for others to find in the future. – netuoso - EOS Titan Aug 22 '19 at 4:14
0

EOS Studio is issuing the command you see in the output:

eosio-cpp -abigen -I include -R resource -contract eos.token -o eos.token.wasm

You should edit the "Custom build command" section to be something like:

eosio-cpp -abigen -I include -R resource -contract eos.token -o eos.token.wasm src/eosio.token.cpp

You may have to alter the src/eosio.token.cpp to your environment.

(The hint to this is the error message telling you at least 1 positional argument is required.)

| improve this answer | |
  • I am just wondering where do I send the parameter for the token such as its name? – djsoyboi Aug 23 '19 at 23:38
  • The answer to solve this specific error with compiling is above. It requires a single positional argument for the source file. If that answers your original question please accept this one and create a new issue for any different errors. – netuoso - EOS Titan Aug 24 '19 at 0:16
  • I am just wondering where do I send the parameter for the token such as its name? – djsoyboi Sep 11 '19 at 22:10
  • I'm not following you exactly. I said you need to edit the "custom build command" section and add the code I put above. Notice how my example adds src/eosio.token.cpp to the command? – netuoso - EOS Titan Sep 11 '19 at 22:12
  • Now I can compile. My second issue is how to I change the parameter for the token like the name and the number of tokens issued – djsoyboi Sep 12 '19 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.