I was getting an Error while starting nodeos.

Error: 3190000 block_log_exception: Block log exception: block log does not contain last irreversible block

If you are getting the same error look at my answer below.

1 Answer 1


To solve this issue, go to your home directory.

Navigate to ~/.local/share/eosio/nodeos

Here you will see two files config and data.

Delete the data folder using rm -rf data/ and start your nodeos again. Error should be gone.


You can use --hard-replay to replay the blockchain to the last irreversible block.

If you don't mind losing accounts that you have created, the first method is the best, however, if you do not want to lose the current accounts, make sure to use the second method.

  • 1
    Thank you! I solved my problem
    – Tom
    Aug 10, 2022 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.