0

I made my own smart contract. and tried to erase my table. But it didn't. I will attach the following error

{
  "code": 500,
  "message": "Internal Service Error",
  "error": {
    "code": 3050003,
    "name": "eosio_assert_message_exception",
    "what": "eosio_assert_message assertion failure",
    "details": [{
        "message": "assertion failure with message: read",
        "file": "wasm_interface.cpp",
        "line_number": 926,
        "method": "eosio_assert"
      },{
        "message": "pending console output: ",
        "file": "apply_context.cpp",
        "line_number": 75,
        "method": "exec_one"
      }
    ]
  }
}

the "read" error message is occurred in datastream.

Wasm file is stored in database and executed by transaction(method : exec_one). But How do error occur in datastream?

  • Do you have some code like check(..., "read") in your contract? – netuoso - EOS Titan Aug 30 '19 at 0:33
  • No.. whether a code check(...) exist , the same error is occurred – T Eom Aug 30 '19 at 2:22
  • Could you provide the code from the contract that is causing this issue. We got the error but without the source context there isn't much we can help you with right now. – netuoso - EOS Titan Aug 30 '19 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.