4

I just started set up my eos dev environment. I started my node as

./nodeos --config-dir config --data-dir data --enable-stale-production --producer-name eosio --plugin eosio::chain_api_plugin

And start my keosd as:

./keosd --data-dir data --http-server-address lochost:8899

I can use cleos to add keys, list keys etc. However when I try to create account:

./cleos -u http://localhost:8899 create account eosio user xxxx xxxx

I see error such as

Error 3110001: Missing Chain API Plugin

Ensure that you have eosio::chain_api_plugin added to your node's configuration!

Error Details: Chain API plugin is not enabled"

But I clear has eosio::chain_api_plugin enabled in my nodeos.

  • Same issue here, looking for an answer. – Damir Olejar Jun 17 '18 at 23:50
  • What I did was run nodeos only without running keosd. You can create account by "./cleos create account eosio user xxx" – Wayne Jun 18 '18 at 16:14
2

As I can not comment yet due to the low reputation as I made the account recently, I have some queries related to your problem.

  1. You are running cleos command at port 8899 whereas you did not mention the port 8899 while starting the blockchain. It might have set the default port 8888 which might be the reason of failing this command.
  2. ./keosd --data-dir data --http-server-address lochost:8899 ---> is it typo? Because it should be localhost:8899.

HTH.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.