0

I tried both ubuntu16.04 and ubuntu18.04 with version 1.8.4 installed on Debian 4.9.144-2 (2019-01-21), and always get below error when start nodeos:

nodeos: /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.2' not found (required by nodeos)

Anyone can help me to figure the problem?

0

You have to Install OpenSSL first.

sudo apt-get update
sudo apt-get install openssl
  • openssl is already installed, but the version seems not matched – Jimmy Guo Oct 15 '19 at 11:35
  • I am working on debian – Jimmy Guo Oct 15 '19 at 11:36
0
sudo apt-get install libssl1.0.2

If your issue is not solved by above command, you had better build openssl by yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.