0

When launching a transaction like:

await eosioApi.transact({
    actions: [
        {
            account: "eosio",
            name: 'newaccount',
            authorization: [{
                actor: "eosio",
                permission: 'active',
            }],
            data: {
                creator: "eosio",
                name: "mynewaccount",
                owner: {
                    threshold: 1,
                    keys: [{
                        key: publicKey,
                        weight: 1
                    }],
                    accounts: [],
                    waits: []
                },
                active: {
                    threshold: 1,
                    keys: [{
                        key: publicKey,
                        weight: 1
                    }],
                    accounts: [],
                    waits: []
                },
            },
        }
    ]
},
{
    blocksBehind: 3,
    expireSeconds: 30,
});

I get the following error

(node:17020) UnhandledPromiseRejectionWarning: Error: fetching abi for eosio: deadline 2020-02-26T14:23:16.796 exceeded by 87us 
at new RpcError (/home/jochen/eos/node_modules/eosjs/dist/eosjs-rpcerror.js:26:28)
at JsonRpc.<anonymous> (/home/jochen/eos/node_modules/eosjs/dist/eosjs-jsonrpc.js:118:35)
at step (/home/jochen/eos/node_modules/eosjs/dist/eosjs-jsonrpc.js:36:23)
at Object.next (/home/jochen/eos/node_modules/eosjs/dist/eosjs-jsonrpc.js:17:53)
at fulfilled (/home/jochen/eos/node_modules/eosjs/dist/eosjs-jsonrpc.js:8:58)
at processTicksAndRejections (internal/process/task_queues.js:93:5)

The server itself says:

error 2020-02-26T14:40:03.271 http-1    http_plugin.cpp:238           handle_exception     ] Internal Service error, http: 2 timeout_exception: deadline 2020-02-26T14:40:03.270 exceeded by 933us 
deadline 2020-02-26T14:40:03.270 exceeded by 933us 
    {"d":"2020-02-26T14:40:03.270","t":933}
    http-1  json.cpp:499 escape_string

Any idea what is the reasin for this? What can I do to prevent this?

1
  • I am also getting this error. My laptop performance is pretty high, so not sure what to do here. Any ideas? – theblockstalk Dec 17 '20 at 17:29
1

You can fix this by starting nodeos while setting

--abi-serializer-max-time-ms

to 50000 or so.

I'm not sure if there's such an option in eos-js but if you get the error using cleos, you can additionally start keosd while setting

--http-max-response-time-ms=

to 1000 or so.

0

It was a performance issue on my computer. At the moment the issue was solved the error vanished.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.