0

Hello I successfully deployed my contract on the jungle testnet on the account rpstestacc13. However when I want to push an action it says that it is missing authority of rpstestacc13.

polo@polo-Ubuntu:~/contracts/rps$ cleos -u https://jungle2.eosio.cr:443 push action rpstestacc13 choice '["rpstestacc13", "rock"]' -p rpstestacc13@active
Error 3090003: Provided keys, permissions, and delays do not satisfy declared authorizations
Ensure that you have the related private keys inside your wallet and your wallet is unlocked.
Error Details:
transaction declares authority '{"actor":"rpstestacc13","permission":"active"}', but does not have signatures for it under a provided delay of 0 ms, provided permissions [{"actor":"rpstestacc13","permission":"eosio.code"}], provided keys [], and a delay max limit of 3888000000 ms
pending console output: 

This is this command I wrote:

cleos -u https://jungle2.eosio.cr:443 push action rpstestacc13 choice '["rpstestacc13", "rock"]' -p rpstestacc13@active`
1

Some actions need eosio.code permission to execute. Try setting eosio.code permission on your contract. To set permission, use

cleos -u https://jungle2.eosio.cr:443 set account permission --add-code rpstestacc13 active

OR

cleos -u https://jungle2.eosio.cr:443 set account permission rpstestacc13 active '{"threshold":1, "keys":[{"key":"YOUR_PUBLIC_KEY", "weight":1 }],"accounts":[{ "permission":{"actor":"rpstestacc13","permission":"eosio.code"},"weight":1}]}'
-p rpstestacc13@owner

For eosio.code details you can refer to this answer

0

Can you confirm that you have and rpctestacc123 account if the account is there make sure to import private_key of that account into your wallet using this

cleos wallet import private_keys -n wallet_name

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.