0

So, I'm just starting and I run a MacOS device. First issue:

"Failed to connect to localhost port 8888: Connection refused" after running curl http://localhost:8888/v1/chain/get_info in MacOS

I successfully started running the node I thought, because a chain of transactions were showing, however there is this connection failure on the port.

What is going on? Thanks for helping.

  • I have the same problem when I attempt this in the Gitpod IDE instead of my local environment... – Andrew Elkins May 18 at 23:30
0

First, check whether you run nodeos with option plugin = eosio::chain_api_plugin. You can add that option when you execute nodeos in command line like $ nodeos --plugin eosio::chain_api_plugin ... or put it into config.ini of nodeos.

Second, if your nodeos is executed remotely, set option http-server-address = 0.0.0.0:8888. This also can be added to command line command or config.ini.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.