0

I'm new to development so hopefully someone can point out what I may have done wrong.

I'm trying to set up an EOS node using Ubuntu VirtualBox on my Windows machine.

I have installed everything needed so far but after running git clone https://github.com/eosio/eos --recursive, I enter ls into the terminal and see eos, great then cd eos, then ls, then the screenshot shows what I'm seeing...no eosio_build.sh.

Anyone know whats going wrong? This is driving me mad!!!

Thanks all.enter image description here

1

You'll find the scripts for building eosio in the scripts-folder.

Do

$ cd scripts
$ ./eosio_build.sh

or

$ ./scripts/eosio_build.sh

to build eosio.

EDIT:

follow this guide to Build from Shell Scripts

or this guide to install prebuild binaries

| improve this answer | |
  • Thanks for you help my friend. However when I enter the above I get 'command not found' so I have tried reinstalling everything and I still end up at the same point...I may just have to give up. No idea what is going wrong here. – Aaron Jun 7 at 10:06
  • Do you know of any good videos guides? I've tried looking but they are a few years old and I still get stuck at the same point! Thanks. – Aaron Jun 7 at 10:07
  • you probably need to add permission to execute with "chmod +x ./scripts/eosio_build.sh" – cmadh Jun 8 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.