0

I am setting up eosio on my mac and when I try to run tail -f nodeos.log I get this error ::plugin_startup failed to bind to port "

0

There are two ports used by nodeos, p2p connection (9876) and http connection (8888). You can change them by adding options when you execute nodeos like:

nodeos --p2p-listen-endpoint=0.0.0.0:9876 --http-server-address=0.0.0.0:8888
                                     ^^^^                               ^^^^
                                     change number here                 here too

You can put those options into config.ini of nodeos. If you want to allow http connection within localhost only, set http-server-address to 127.0.0.1:PORT instead of 0.0.0.0:PORT.

| improve this answer | |
  • Ok, I am trying to put those options into config.ini and I am still getting the same error message. I think I don't have it in the right place. – Kaya Jones Jun 16 at 20:28
  • Also what do i change the numbers too because i tried to run what you provided me and i still see the same error – Kaya Jones Jun 16 at 20:30
  • Oh, you need to use different numbers in example, not 9876 and 8888. Change them to any other numbers. – conr2d Jun 17 at 5:26
  • ok so i did that but then it says connection refused – Kaya Jones Jun 18 at 13:37
  • What connection? If you mean cleos, you need to set url explicitly, because cleos tries to connect to 127.0.0.1:8888 by default. Try cleos -u http://127.0.0.1:YOUR_CHANGED_PORT get info. – conr2d Jun 18 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.