0

Hello stackExchange community.

I am trying to follow along the Udemy Elemental Battles dApp tutorial, I have created a smart contract with login functionality and compiled it successfully, but when I tried to deploy it using eosio account I got an error:

transaction declares authority '{"actor":"eosio","permission":"active"}', but does not have signatures for it under a provided delay of 0 ms, provided permissions [], provided keys ["EOS6jfCTkYUA7SYaFDKkGHjMwKEDT9JNJCNonaTGGWmN63TDPodXb"], and a delay max limit of 3888000000 ms

Looking back at the tutorial video I have realized he didn't deploy it using eosio account,, rather he created a new account for that. Trying to create a new account I get exact same error. First I thought issue is because I have no staked RAM and CPU but neither does the guy in the tutorial and I'm kinda lost. Googling this all day and just going in circles...

Here is the actual video I've been watching (it's from free course of Udemy following official elemental battles tutorial from EOS)

https://youtu.be/4uu6AbTa5Hk?t=663 => this is where I get that error.

I'm not sure what to do next. I am new to EOS backend and honestly very confused right now. I have generated couple of pub / private keys and tried creating new account using them but same error occurs. Any ideas? Thanks!!

  • Do you use public testnet such as that of block.one, jungle or kyrin? If you use fresh-started local testnet, you can create account with known default private key of eosio, 5KQwrPbwdL6PhXujxW37FSSQZ1JiwsST4cqQzDeyXtP79zkvFD3. In public testnet, you need to create account through testnet website. – conr2d Jul 15 at 5:42
  • I've gone the cmd route. Im running a local nodeos and dropped the whole EOS Studio thing. To be honest getting used to the terminal was the best decision I made. I will keep using VSCode and terminal. I've also dropped watching tutorials. Trial and error baby! Thanks for dropping by and trying to help anyway... Have a nice day! – Milos Krstic Jul 17 at 23:37
0

Try to install other version of eosio image than the latest one. I encountered the same problem so I later used the version v1.8.9 and it worked out for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.