1

I'm working off of this:

https://developers.eos.io/welcome/latest/getting-started/development-environment/start-your-node-setup

1.1: keosd starts correctly.

1.2: after I enter the nodeos commands I get the following:

[2] + exit 254 nodeos -e -p eosio --plugin eosio::producer_plugin --plugin --plugin

I'm unsure if that's expected or an error message.

2.1: i get the following after I run $ tail -f nodeos.log

std::exception::what: Unknown option 'bnet-follow-irreversible' inside the config file /Users/wilfra/Library/Application Support/eosio/nodeos/config/config.ini

error 2020-10-22T12:28:00.847 thread-0 main.cpp:131
main ] /Users/anka/eos/libraries/appbase/application.cpp(298): Throw in function bool appbase::application::initialize_impl(int, char **, vector<appbase::abstract_plugin *>) Dynamic exception type: boost::wrapexceptstd::runtime_error std::exception::what: Unknown option 'bnet-follow-irreversible' inside the config file /Users/wilfra/Library/Application Support/eosio/nodeos/config/config.ini

error 2020-10-22T12:35:50.406 thread-0 main.cpp:131
main ] /Users/anka/eos/libraries/appbase/application.cpp(298): Throw in function bool appbase::application::initialize_impl(int, char **, vector<appbase::abstract_plugin *>) Dynamic exception type: boost::wrapexceptstd::runtime_error std::exception::what: Unknown option 'bnet-endpoint' inside the config file /Users/wilfra/Library/Application Support/eosio/nodeos/config/config.ini

I'm not sure what other information is needed here. I'm on MacOS and just upgraded to the latest version of EOSIO via Brew.

Thanks for any help with this.

1

I was given a solution by conr2d on Telegram.

The problem was I had an old config.ini file. I deleted it and ran the nodeos commands again and it solved these errors. Running nodeos generates a new config.ini if one does not exist.

File is in: ~/Library/Application\ Support/eosio/nodeos/data

1

The key to the problem is this part of the error message:

std::exception::what: Unknown option 'bnet-follow-irreversible' inside the config file /Users/wilfra/Library/Application Support/eosio/nodeos/config/config.ini

It tells you that you have an option in your config.ini file that is no longer valid, and removing it would fix the problem (or at least reveal the next option in your config file that wasn't supported)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.