0

Hello i am trying to create eosio.system contract but its keep giving me this Error 3080004: Transaction exceeded the current CPU usage limit imposed on the transaction Error Details: transaction was executing for too long 50017us pending console output: please check and let me know if you have any solution thank you

0

I guess your Node is not performant enough for standard-config so the maximum transaction-time is exceeded and the contract isn't successfully pushed. Assuming you are running a private development-chain, pass the following config to set it to a higher value when starting nodeos.

(Note that from what I know values higher than 350-400 do not make sense as a block is 500ms and only 80% of the block-time can be used to process transactions)

  --max-transaction-time arg (=30)      Limits the maximum time (in 
                                        milliseconds) that is allowed a pushed 
                                        transaction's code to execute before 
                                        being considered invalid
4
  • solved . Thank you it was very helpfull May 3 at 9:56
  • @ Awais Sakhi just writing a comment that your question is solved is of no use, you have to press the button on the left above the "0". Others will probably not continue to answer your questions if you do not mark the answers as correct.
    – cmadh
    May 3 at 22:53
  • i pressed up and down both im sorry should i press up or down? May 4 at 4:05
  • You should press up If the answer is correct and down If you think the answer is incorrect, outdated or of Low quality.
    – cmadh
    May 4 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.