I'm following the instructions from https://developers.eos.io/eosio-nodeos/docs/docker-quickstart and when I run

sudo docker run --rm --name eosio -d -p 8888:8888 -p 9876:9876 -v   
/tmp/work:/work -v /tmp/eosio:/mnt/dev/data eosio/eos-dev /bin/bash -c 
"nodeos -e -p eosio --plugin eosio::wallet_api_plugin --plugin 
eosio::wallet_plugin --plugin eosio::producer_plugin --plugin 
eosio::history_plugin --plugin eosio::chain_api_plugin --plugin 
eosio::history_api_plugin --plugin eosio::http_plugin -d /mnt/dev/data -- 
http-server-address= --access-control-allow-origin=* --contracts-console"

I'm getting

docker: Error response from daemon: Failed to inspect container 4d13c13b0e91bc79aaff44e9b185ae4d3b5bd69c0b19e988cf0b042e92db8bd3: Error response 
from daemon: readlink /var/lib/docker/overlay2/l: invalid argument.

Any idea how to resolve this issue?

1 Answer 1


It was due to corrupted images. If you're using mac, you can resolve it by going to Preferences menu, click on Reset tab, and click "Remove all data." Then run docker pull eosio/eos-dev again.

  • Nice work, can you mark this as solved with the checkmark button? Jul 3, 2018 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.