0

I have 3 accounts:

  1. Contract Account.
  2. Storage Account.
  3. Recipient Account.

I made a smart contract to give out tokens from Storage Account to the Recipient Account using a claim function from the Contract Account.

Current error I'm getting is Error: missing authority of {Storage Account}.

I've already given eosio.code permission to Contract Account.

I'm guessing the fix to this problem is to add 2 permissions/authorizations to the claim function of the smart contract but I don't know how to do that.

enter image description here

4
  • Have you been able to solve this? I'm facing a similar issue.
    – soulseekah
    Sep 2 '21 at 11:55
  • Try asking here: t.me/joinchat/0uhWYfXVpPlkNTA1
    – Nat
    Sep 7 '21 at 18:36
  • Hi @soulseekah not yet, still wondering how to do this, I asked on the telegram channel provided above but one of the volunteers were kinda toxic so went out right away
    – Jesseeeee
    Sep 10 '21 at 11:59
  • can you pls post here the link to the telegram channel with your post in that dev telegram channel? I tried to find it but I couldn't.
    – ovi
    Sep 16 '21 at 10:53
0

you can send a vector of permissions instead just one:

https://developers.eos.io/manuals/eosio.cdt/latest/structeosio_1_1action#function-action-33

however, did you try to send just the Storage Permission instead of what you are sending now?

2
  • 1
    Hi, I'm really late to reply to you. Sorry about that, I haven't done that yet as I've made a different way of handling this which is adding the tokens to the actual contract's account, giving the contract code account active permission and allowing it to directly do transfers on behalf of its own account. Not sure if I made sense but that's how I solved the problem I had. I think this is kinda the same as what you said just in the sense that i had used the contract itself to do transfers. Do you think this is okay? Thanks!
    – Jesseeeee
    Nov 5 '21 at 16:01
  • that works as well, so you eliminated the storage account from equation.
    – ovi
    Nov 10 '21 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.