0

I am trying to install and run an EOS node on macos.

I installed eosio with brew.

I used

brew tap eosio/eosio
brew install eosio

Everything went alright. But after installation the following folder was supposed to be created /usr/local/eosio which it did not.

Also, from what I know I should have a folder in my Application Support with the nodeos that was installed with eosio ( since I want to edit the configuration file for nodeos ). However, I don't have the following folders.
/Users/[user]/Library/Library Support/eosio/nodeos

Note that nodeos --help works, as well as cleos --help

I am not sure if I am doing something wrong or the folders have been changed.

4
  • 1
    Can you try which nodeo or which cleos ? This should return the path to your installation.
    – TeeAttack42
    Oct 12 at 9:17
  • @TeeAttack42 Thanks for the response. So which nodeos returns /usr/local/bin/nodeos and cleos is as well in the same folder. I tried which eosio with the hope that it would show a path but it returned nothing.
    – Alex Matei
    2 days ago
  • I think I found the eosio folder, it's in /usr/local/Cellar/eosio/2.1.0/bin which contains the nodeos, cleos, keosd binaries. However, I still can't find the config for nodeos which was supposed to be in Librabry Support.
    – Alex Matei
    2 days ago
  • Problem solved. After I spun a node with nodeos, the eosio folder in Library Support seemed to magically appear.
    – Alex Matei
    2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.