I am really not certain what happened here, but I was trying to change my keypair in the config.ini file because I could not get it to register as a block producer. And then after restarting it I have this error:

["testnet.protonchain.com:9876"]received go_away_message, reason = wrong chain

I tried to revert back to the previous key to at least get it to sync again. But now it will not do anything.

Does anyone know how to fix this? I tried running with ./start.sh --delete-all-blocks --genesis-json genesis.json again thinking maybe if I just restart the sync .. does not work. Thoroughly confused, any ideas?

Thanks in advance..

1 Answer 1


Someone from the telegram channel helped me find the solution. This is what worked for me -- restoring from the latest snapshot:

cd /opt/ProtonTestnet/protonNode
rm blocks/*
rm state/*
cd /opt/ProtonTestnet/protonNode/snapshots/
wget http://backup.cryptolions.io/ProtonTestNet/snapshots/latest-snapshot.bin
unzstd  latest-snapshot.bin
cd /opt/ProtonTestnet/protonNode
./start.sh --snapshot /opt/ProtonTestnet/protonNode/snapshots/latest-snapshot.bin

After I did this, I might add I was no longer getting this error while trying to register as a block producer on the testnet:

'{"actor":"luminaryvisn","permission":"active"}', but does not have signature -

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.