0

I'm running 6 mainnet archive nodes, today morning onwards a few blocks are returning 500, internal server error!

curl --location $url/v1/trace_api/get_block --header 'Content-Type: application/json' --data '{"block_num": "356339452" }' | jq .

{
  "code": 500,
  "message": "Internal Service Error",
  "error": {
    "code": 3015013,
    "name": "unpack_exception",
    "what": "Unpack data exception",
    "details": [
      {
        "message": "Stream unexpectedly ended; unable to unpack field 'to' of struct 'transfer'",
        "file": "abi_serializer.cpp",
        "line_number": 374,
        "method": "_binary_to_variant"
      }
    ]
  }
}

The nodes are running v4.0.5.

I tried rewinding the node back using

nodeos --genesis.json /root/local/genesis.json --data-dir /data --config-dir /root/local \
--hard-replay-blockchain --terminate-at-block 356339451

But afterwards it complained about database version mismatch.

warn  2024-02-08T11:54:53.441 nodeos    chain_plugin.cpp:1077         plugin_initialize    ] 3060005 bad_database_version_exception: Database is an unknown or unsupported version
state database version pre-dates versioning, please restore from a compatible snapshot or replay!
    {}
    nodeos  controller.cpp:687 validate_db_version

error 2024-02-08T11:54:53.472 nodeos    main.cpp:161                  main                 ] 3060005 bad_database_version_exception: Database is an unknown or unsupported version
state database version pre-dates versioning, please restore from a compatible snapshot or replay!
    {}
    nodeos  controller.cpp:687 validate_db_version
rethrow
    {}
    nodeos  chain_plugin.cpp:1077 plugin_initialize

So I tried syncing from a recent snapshot snapshot-2024-02-08-04-eos-v6-0356339018.bin

Even then this block was returning with the same response.

There are a few more blocks with the same error in the next 10k range!

356339452
356339534
356340111
356340363
356340822

Is this network wide issue, or only for me, how to recover?

Only thing left to do is to upgrade to v5.0.0 which I'm currently trying.

Update: the upgrade also didn't help.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.