2

I'm trying to use the CLEOS command line to vote, but as I follow the tutorial on developers.eos.io I'm running into problems pulling the Docker image.

So I've installed Docker on a fresh installation using Linux Mint Cinnamon. When I run docker --version it responds with Docker version 1.13.1 build.. then it shows a short alpha-numeric build code showing that it's installed.

So then I run docker pull eosio/eos-dev and it's coming back with an error saying Warning: failed to get default registry endpoint from daemon

Is this happening because the Mainnet hasn't be validated and opened to the public yet? If anyone can help me with this so I can vote using CLEOS, I'd appreciate it.

1

Two suggestions:

1) Try to run it with admin privileges

sudo docker pull ...

2) If that still fails, clean your docker images/volumes/containers. Afterwards you can try the production image. With

sudo docker pull eosio/eos

Edit:

Seems that your docker daemon is not running.

Try to run

dockerd

Maybe use some of the answers from this link

  • Actually I just figured out a workaround, I skipped to the next step and simply ran the startup for the EOSIO node and it worked! It said it was unable to find the image locally, so it automatically started pulling it from eosio/eos-dev. Then I ran sudo docker logs --tail 10 eosio and it began giving me the produced blocks. I also ran localhost:8888/v1/chain/get_info and I got a similar readout to what the tutorial said I'd get! So it looks like I have a node running locally on my Linux!! Now CLEOS is giving me problems, so I have to figure that out but I'm going to take a break – Brian M. Jun 9 '18 at 21:43
  • Nice to hear. Then good luck with that. – TeeAttack42 Jun 9 '18 at 21:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.