0

I've installed CLEOS and I've created a local wallet(that I named), and public and private keys through the command line. I'm trying to figure out how to create account soon.

But obviously the first thing I wanted to check was my account balance by pulling up my account and I'm getting an error. I'm running the command line with Admin privileges, so that shouldn't be an issue. Here's what I'm entering...

./cleos get account (NAME) I put in my account name given to me by EOS Authority

Then I hit enter and it comes back with an error message that reads...failed with error unspecified(0) - unknown key

Should I put in my public or private key then? The instructions on developer.eos.io doesn't say to. I just want a way to verify independently that my account has the proper balance. I registered and everything through EOS Authority and even verified that my account was accurate after the snapshot. So clearly I'm doing something wrong.

I've also compiled the EOS Mainnet which took hours lol and ran the 35 tests, I passed all but 8 of them including the Nodeos_run_test. Idk if that's the problem, but I DO have the Mainnet set up too.

  • what does cleos get info report? – Todd Fleming Jun 10 '18 at 19:59
  • "server_version": "26ec83de", "chain_id": "cf057bbfb72640471fd910bcb67639c22df9f92470936cddc1ade0e2f2e7dc4f", "head_block_num": 167328, "last_irreversible_block_num": 167327, "last_irreversible_block_id": "00028d9f953a8e336173b67e29fdc40f8b29bac76de0f7851f0d961cf1fe6473", "head_block_id": "00028da0e592ff1a5b8c4462cea7203d594e61dbbab984aaabf2a0996d0ce00e", "head_block_time": "2018-06-10T21:43:11", "head_block_producer": "eosio", "virtual_block_cpu_limit": 200000000, "virtual_block_net_limit": 1048576000, "block_cpu_limit": 199900, "block_net_limit": 1048576 – Brian M. Jun 10 '18 at 21:52
  • That chain_id doesn't match the mainnet; your nodeos instance is either producing a testchain, or connected to another testchain. – Todd Fleming Jun 12 '18 at 0:32
  • Hmm...I'm assuming I have to just find the right Chain ID then and update config.ini to have NODEOS set up? – Brian M. Jun 12 '18 at 19:38
1

./cleos get account (NAME) implies you're connecting to a locally running nodeos (which I have to assume is not configured to connect to the mainnet).

To connect to the mainnet you need to use the -u option with a valid url, for example:

cleos -u http://185.109.149.236:8888 get info

or

cleos -u http://185.109.149.236:8888 get account YOURACCOUNTNAME

PS: the 185.109.149.236 ip is on the mainnet at this time, but I am not sure which BP or candidate it belongs, pulled it from the eos developers channel. I'll update this when I have better information.

  • Is there a good tutorial about how to connect a local NODEOS node to the mainnet? I may just have to create a separate question because I think that's my problem based on what you wrote. I followed the steps on developer.eos.io point by point, but it left something out. I don't see where a config.ini file was set up on my Linux when EOS was compiled and apparently if I don't have that then I'm S.O.L. and can't connect. The developer site says I can use the Command Line to configure NODEOS, but it has even less information about how to do that. The config.ini methods seem quickest and easiest – Brian M. Jun 11 '18 at 2:01
  • it's there: developers.eos.io/eosio-nodeos/docs/configuration-file – Vlad Jun 11 '18 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.