2

I get the following error when importing eos (1.0 from github) as a clion project. Does anyone know where I can set BOOST_ROOT?

/home/usera/clion-2018.1.3/bin/cmake/bin/cmake -DCMAKE_BUILD_TYPE=Debug -G "CodeBlocks - Unix Makefiles" /home/jack/eos -- Using custom FindBoost.cmake CMake Error at libraries/fc/CMakeModules/FindBoost.cmake:1129 (message): Unable to find the requested Boost libraries. Unable to find the Boost header files. Please set BOOST_ROOT to the root directory containing Boost or BOOST_INCLUDEDIR to the directory containing Boost's headers..

2

I think it has to do with the most recent EOSIO git repo having the boost root as ~/opt/boost and the CMake is looking for something like ~/opt/boost__1__6__6

The way I solved this is by importing the entire EOSIO folder into Clion (after doing ./eos_build.sh and sudo ./eos_install.sh) and going to File ==> Settings ==> Build, Execution, Deployment ==> CMake

and putting inside CMake options: -G Ninja -DBOOST_ROOT=~/opt/boost -DWASM_ROOT=~/opt/wasm -DOPENSSL_ROOT_DIR=/usr/bin/openssl bin-DBUILD_MONGO_DB_PLUGIN=true -DENABLE_COVERAGE_TESTING=false -DBUILD_DOXYGEN=false

I think this overrides the CMakelists files by explicitly telling Clion where to look for Boost with

-DBOOST_ROOT=~/opt/boost

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.