2

When I set the eos system contract with mainnet-v1.0.3, it always give me a error, that the transaction is too long and give me the belong error

{"now":"2018-06-14T08:16:44.376",
"deadline":"2018-06-14T08:16:44.369",
"start":"2018-06-14T08:16:44.339"}

any body can help me to solve the problem, I am get in stuck.

  • What do you mean by main net v1.0.3? Are you running this on your local computer as a single node test net? Or actually trying to deploy this on the main net? – John Williamson Jun 14 '18 at 9:38
  • @JohnWilliamson thanks, solved it in set max-transaction-time, I have test nodes in my single machine! – Jimmy Guo Jun 14 '18 at 10:11
  • 1
    @KemmyGuo Happy that you found a solution. Consider writing it as an answer (you can answer your own questions on stackexchane) and mark it as the correct answer by clicking the V next to the answer. This will help future visitors with a similar question. – Ami Heines Jun 14 '18 at 11:49
  • 1
    Awesome @KemmyGuo for future reference, 'main net' typically refers to the main network where everyone is voting at the moment. If it's just on your local computer and not connected to anything else it's not related to the main net and you can just call it a single node testnet. – John Williamson Jun 14 '18 at 12:49
2

To avoid leaving this question unanswered:

OP solved their issue by increasing the max-transaction-time in their config file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.