I'm running 3 cores confirmed on virtual machine (per solve for similar problem), and I'm still getting this error:

~/eos$ eosio-cpp -abigen -o hello.wasm hello.cpp error: error reading '/home/corey/eos/hello.cpp' 1 error generated. Error while processing /home/corey/eos/hello.cpp. abigen error

any thoughts?

1 Answer 1


It says there is (likely) no file named hello.cpp in your /home/corey/eos directory.

Check the previous steps in the tutorial. Find the step which was supposed to put this file there. Find out what happened instead.

  • 1
    soooooooooooooooo... that file path was there, and the file is there, but i couldnt replicate getting to it w cd. ive been using command line interface for about 8 days now lol, im sure this would have been obvious to someone experienced. i ran the abigen code from within the extant /hello directory and it worked instantly. #HeadDesk. tks for the redirecct Gassa!! Commented Apr 18, 2019 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.