My EOS account was hacked, I looked into transactions and I can see that owner and private key were changed. Now I tried to regain control of my EOS account, but I can't change owner key, neither active key. I tried wit EOSToolkit and Scatter and I have my privet and public key from a genesis.

When I try to change, it's always a failure says:

  "code": 500,
  "message": "Internal Service Error",
  "error": {
    "code": 3090003,
    "name": "unsatisfied_authorization",
    "what": "Provided keys, permissions, and delays do not satisfy declared authorizations",
    "details": [
        "message": "transaction declares authority '{\"actor\":\"gi3tanrtgmge\",\"permission\":\"owner\"}', but does not have signatures for it under a provided delay of 0 ms, provided permissions [], provided keys [\"EOS7zty2GiXDus3TRtvjbJ5aCf2nJDXgAKt97f6dHgQnW2N1zpmVk\"], and a delay max limit of 3888000000 ms",
        "file": "authorization_manager.cpp",
        "line_number": 520,
        "method": "check_authorization"

Is there any way to gain back control of my account?

  • Hey guys I’m having the same issue, but I look my account name and it said don’t exist in eos gi4dqnbwgage, can they delete it? Commented Mar 10, 2021 at 4:12

2 Answers 2


With your private keys stolen, cracker already replaced your private keys making your current private key useless. It's natural to get such error because your key no longer could prove authority of the acocunt.

EOS has its own EOS core arbitrary forum ECAF taking care of dispute resolutions.

Perhaps reading this medium article might be helpful.

Again, your private key is already stolen, so you should make a new one when ECAF does solve your problem.

Good luck with your account.


Unfortunately ECAF isn't quite functioning as it was envisioned before the mainnet was launched. The hacker will try to move your tocken to an exchange of his choice once it's get refunded in 72 hours. If you can prove your ownership pre-theft, contact exchange. ECAF will take weeks if best, which is likely to be already too late.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.