0

My test contract cpp file is in /home/boby/hackathon/contracts/test/ folder, when I run

cleos set contract bob  /home/boby/hackathon/contracts/test/ -p bob@active

I get an error

unable to resolve path /home/boby/hackathon/contracts/test

What is it I am doing wrong?

  • Can you try without the last slash in the path maybe? – Ami Heines Nov 25 '18 at 8:56
  • the problem persists – ovicko Nov 25 '18 at 9:58
  • I am on virtual machine, could this be problem? – ovicko Nov 25 '18 at 9:59
  • I've built on VM before without issues. Perhaps try setting a relative path instead of an absolute path. – Nat Nov 25 '18 at 11:23
  • relative path not very sure of what it is in this case – ovicko Nov 25 '18 at 11:34
1

Make sure the directory name and file names are same. For example, you have stored your files in a directory named test. So that, the contract files should be test.cpp, test.hpp, test.wasm, test.wast and test.abi

-1

Make sure that in /home/boby/hackathon/contracts/test/ folder,there exists your_contrat_name.wasm and your_contract_name.abi (bob.wasm bob.abi) file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.