0

I am running several docker images, one of them is EOSIO blockchain. The block production log it produces fills the terminal. I don't want to see it, the logs of other containers are much more important, and not the blockchain's logs.

I don't want to detach from all containers, and docker-compose does let you detach from only one container.

I tried to redirect the logs into a file. But there comes another problem. When I stop the container with Ctrl+C, the next time I run, I got 'database dirty flag set' which means abnormal exit. I can add '--hard-replay', but it's not the right way, I think.

1

The new documentation explains how logging works in nodeos.

You have to create a logging.json file in the config_dir for nodeos.

I believe (although I haven't tested it), that you can disable logging with:

{
  "name": "consoleout",
  "type": "console",
  "args": {
    "stream": "std_out",
  },
  "enabled": false
}
|improve this answer|||||
  • This worked, thank you. Actually, I have solved my problem with tini, after reading this post. And that way I'm redirecting logs, so I save them. – Tigran Sahakyan Feb 7 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.