1

Just downloaded eosio v1.3.0 and tried to run nodes but get the following exception:

~/eos/build/programs $ nodeos 2018-09-23T15:25:41.459 thread-0 main.cpp:136 main ] Throw location unknown (consider using BOOST_THROW_EXCEPTION) Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::program_options::unknown_option> > std::exception::what: unrecognised option 'wallet-dir'

What boost program is getting this error and how can I set the wallet-dir variable to resolve the issue?

  • I think you need to change your config.ini you are using old config.ini file. – Nirdesh Kumar Choudhary Sep 24 '18 at 4:17
1

[Solved] You can find the correct config.ini file from the developers portal. (I was altering the wrong config.ini file earlier.)

In the .local/share/eosio/nodeos/config/config.ini file, commenting out the unlock-timeout and wallet-dir settings fixed the problem.

|improve this answer|||||
  • 1
    Yes exactly the path is .local/share/eosio/nodeos/config/config.ini. I don't use docker so in my case this is easy. – Nirdesh Kumar Choudhary Sep 27 '18 at 5:04
0

You need to change your config.ini file.

Unknown configuration items in config.ini will now error on startup (#5678)

Prior to 1.3.0 unknown configuration items in config.ini would be silently ignored. This behavior has been changed in 1.3.0 to an error that prevents startup of nodeos. Users with old auto-generated config.ini files may need to remove some options that are no longer available in nodeos for example wallet-dir or unlock-timeout

For more info you can go https://github.com/EOSIO/eos/releases and check v1.3.0 release. There are other changes also.

|improve this answer|||||
  • So I did a complete rebuild, using the v1.3.0 version from github, which removed all the old configuration files, but I still get the same error unrecognised option 'wallet-dir'. Now I can only see the config.ini under eos/Docker/ directory and no where else (and I'm not using Docker)....So where else is the wallet-dir being set or passed as an argument to nodeos? – Gunnar Pope Sep 26 '18 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.